Question
Capture is getting the following error intermittently on the Oracle ASM environment:
F_JT0400: Log scanning error F_JZ1517. Non-Terminal page at block 7919201 in Redo Logfile with sequence 144748 failed CRC test. This happens at page 0 out of 1 in total.
Environment
HVR: Oracle with ASM on source
Answer
To resolve this error, please add the environment action, HVR_VASM_MODE=Batch
, for the source group and run HVR initialize or activation with scripts and jobs.
Cause
HVR queries the ASM system. The queries sometimes return corrupted data. It happens when capturing stays on the boundary of the latest online redo log. It happens almost always (99% of cases) when HVR queries data for RACs node 2.
It is because node 2 is less active than node 1. Why ASM returns corrupted data is not yet known. After getting data, HVR caches it. HVR_VASM_MODE=Batch
disables data caching received through the VASM interface.