Issue
A record was deleted from the source and later imported via XML. It is still marked as: _fivetran_deleted = true
Environment
Connector: ServiceNow
Resolution
- Restore the record from the ServiceNow User Interface (UI).
- Re-sync the table.
Cause
We store the last date of deletion for every table and use it as the beginning date.
Once the record is restored in the UI, it will be removed from the sys_audit_delete
table.