Issue
A field that is available in the source/application database is missing in the warehouse.
Environment
Database or Application Connectors
Resolution
Check the below steps to understand the cause of this:
- Verify in the Schema section of the connector if the table or field is enabled for sync.
- For API connectors, check the ERD diagram find in the Schema Information section of the connector documentation to verify the table it may be in. Sometimes the name will be slightly different than the name found in the Source Application UI.
- Verify this field contains data in the source.
- Is it a custom field, and if so does the connector support syncing custom data? This can be seen in the Features section of the connector documentation.
- Does the connector ERD diagram or documentation give reference to this field? If not, then it may not be synced. Reach out to support to understand/submit a Feature Request.
- Are there permissions set in the source that are preventing access to the Fivetran-connected user?
If after following these steps the cause is not clear, please submit a Support ticket.
Cause
Potential causes:
- Table or field is not enabled for sync.
- There is no data in the source. In most cases, Fivetran does not sync empty tables or columns. More info.
- The field is not supported for sync.
- The field may be synced to a different table than expected.
- Permissions in the source application/database may be preventing the connector from accessing the field.