Question
Payout data for connected accounts exist but it is not synced to the warehouse, even though the documentation has been followed.
Environment
Connector: Stripe
Answer
Please open a support ticket and let us know you want to sync Payout data - we will add this feature to your account.
Following our confirmation the feature has been added:
- Using these docs, create an API key in Stripe with no restrictions
- Log in to your Fivetran account and navigate to the setup for your Stripe connector
- In the field for API Key, please enter the unrestricted API key you just generated
- Save & Test
Cause
There is an issue with Stripe where restricted API keys cannot currently be used to retrieve connected account data.