Issue
The Salesforce connector is continuously rescheduled because 90% of its API limit has been reached. The following reason is given:
90% of the API limit is reached, Consumed [X] calls of the total allowed 109000 calls.
Environment
Connector: Salesforce
Resolution
Please visit our Documentation for information relating to the Salesforce API limit.
There are two recommendations that may help you to avoid this alert:
- Tie different credentials to the Salesforce account you are trying to connect with Fivetran and use each of them for various applications/connectors.
- Increase the API limit on your end. Please check this Salesforce guide which may help.
Cause
This usually happens if multiple connectors/ applications besides Fivetrarn make API calls to the same Salesforce account.