Question
Why does it appear that my connector is not releasing the WAL logs?
Environment
Connector: PostgreSQL
Answer
Option 1: Drop and recreate the replication slot
- Pause the connector.
- Delete the replication slot in the source.
- Allow the database to the checkpoint.
- Create a new replication slot.
- Click the Setup tab.
- Click the Edit connection details link.
- Click Re-sync All Historical Data on the setup page.
- Unpause the connector.
Option 2: Allow the sync to continue
- Check to see how much disk space is available.
- Add more space if needed.
- Allow existing sync to continue to run.
Cause
The incremental sync is taking longer to read and update changes in the destination. This can cause the WAL logs to build up and consume a lot of disk space. This could be because of one of the following reasons:
- A lot of tables selected in the connector to sync
- A high rate of change in the database.
- WAL slot is not advancing (stuck)