Issue
In the Jira connector, there are two columns, email
and username
, which are both empty.
Environment
Connector: Jira
Resolution
In place of usernames (as specified in this article), you can use the accountId
field to identify individual users.
There is also a workaround that could retrieve the user emails - Each Jira user has the ability to change their own privacy settings (more about that here), with the following being the most important section:
Apps may receive access to email address in the following ways:
- Individuals have unhidden their email address from public.
- Apps have received explicit consent from individuals through a 3LO consent flow.
- Apps using admin installation and consent flows (i.e. an admin has installed and consented on behalf of end users) have been approved to access the email API.
Keep in mind, the access to email address offered under #s 1 and 2 above can change based on user action. Individuals may choose to hide their email address at any time by changing their profile visibility settings. They may also choose to revoke consent previously given to an app to access to their personal account details via a 3LO flow.
Each user needs to change their privacy settings to allow their email to be shared. This may be an issue if you have a significant number of users, or if users have not indicated whether they want to share their email addresses.
Cause
Due to their compliance with GDPR laws, Atlassian no longer supply this sort of data via any REST APIs (which Fivetran uses to pull the data). You can read more about that here.