Issue
The accounts which were syncing successfully before have started to show the error below. No data for these accounts are loaded.
{
"event" : "warning",
"data" : {
"type" : "permission_denied",
"message": "Skipping Ad Account act_1xxxxx because it no longer exists in the Marketing Graph API"
}
Environment
Connector: Facebook Ads Insights
Answer
It is possible that the user who had access to these accounts has been changed or removed. Check who has permission to the relevant accounts and reauthorize the connector with the right permissions by following the steps below:
- Access the Fivetran connector dashboard.
- Pause the connector by clicking the toggle from the top, right-hand corner.
- Click the Setup tab at the top of the page.
- Click Reauthorize.
- Login with the new connecting user.
- Click Save and Test.
- Unpause your connector.
To avoid this from occurring again please make sure to use a specific user just for Fivetran.
Cause
Change of the Fivetran user with all the permissions.